Loading...
Deal Detail
Tenda A9 Wireless N300 Universal WiFi Range Extender (UK Plug)
Tenda A9 Wireless N300 Universal WiFi Range Extender (UK Plug) A9 is a wireless N300 universal range extender, specially designed to extend the exisiting WiFi coverage and improve the signal strength. With one button extension, smart signal LED, wall-mount design and universal compatibility, it is easy for users to boost wireless networking. A9 is an ideal choice for you to eliminate WiFi dead zones and optimize your networking. • 300 Mbps 802.11n speed. • 2 x 3 dBi external antennas boost signal to extend WiFi coverage up to more 200m. • One button extension help to extend WiFi coverage easily. • Smart WiFi Signal Strength LED help to choose optimum location easily. • Compatible with main brands 802.11n standard wireless routers and WiFi DSL. • Support SSID Hiding Standards & Protocol IEEE802.11b,IEEE 802.11g, IEEE 802.11n Interface None Buttons None Power Consumption N/A Antennas 2 x 3dBi external non-detachable Frequency 2.412GHz - 2.484GHz Data/Signal Rate 802.11b: 11Mbps 802.11 54Mbps 802.11n: 300Mbps Reception Sensitivity 11b: -95dBm 11 -76dBm 11n: -73dBm 802.11b: DSSS / BPSK / QPSK / CCK 802.11 OFDM / DSSS / BPSK / QPSK / CCK 802.11n: OFDM / DSSS / BPSK / QPSK / CCK Wireless Modes Range Extender Repeater Mode (Client AP) Wireless Functions RFC768 UDP RFC791 IP RFC792 ICMP RFC793 TCP Channel Bandwidth: 20/40MHz (default) Wireless Security Encryption Mode: Mix WPA-PSK/WPA2-PSK WPA Algorithm: TKIP System Requirements N/A Package Contents N/A Regulations/Certifications RFC768 UDP RFC791 IP RFC792 ICMP RFC793 TCP Channel Bandwidth: 20/40MHz (default) Dimension (W x H x D) 111 x 56 x 47.7 mm Weight 13 kg Additional Features DHCP Server: Support System Tool: Upgrade, Reset to Factory Default, Login Password, System Log, Reboot

£15.08

Similar Deals

 
Product Product

BOSCH Light Bulbs VW,AUDI,MERCEDES-BENZ 1 987 302 078 Bulb, spotlight

£4.30

From AUTODOC

 
Product Product

BOSCH Light Bulbs VW,MERCEDES-BENZ,BMW 1 987 302 153 Bulb, spotlight

£5.84

From AUTODOC

 
Product Product

BOSCH Light Bulbs RENAULT 1 987 302 604 Bulb, licence plate light

£1.46

From AUTODOC

 
Product Product

BOSCH Air filter SUZUKI 1 987 429 125 12337452,1378083000,1378083000 Engine air filter,Engine filter 1378083000,1378083010,99000990YJ002

£8.59

From AUTODOC

 
Product Product

BOSCH Air filter TOYOTA,DAIHATSU 1 987 429 137 1780187401,1780187401000,1780116020 Engine air filter,Engine filter 1780116020,178011602083,1780116040

£9.04

From AUTODOC

 
Product Product

BOSCH Pollen filter MERCEDES-BENZ,CHRYSLER 1 987 432 001 05101438AA,05101439AA,5101438AA 5101439AA,71775179,K05101439 ...

£10.40

From AUTODOC

 
Product Product

BOSCH Pollen filter FIAT,PEUGEOT,CITROËN 1 987 432 042 6447J0,6447TY,6479A0 1312764080,1312766080,6001073278,71771740, ...

£10.46

From AUTODOC

 
Product Product

BOSCH Pollen filter TOYOTA,SUBARU,LEXUS 1 987 432 085 8713906030,8713928010,8713932010 87139YZZ29,MZ312931,72880AG000,72880AG0009 ...

£8.44

From AUTODOC